Skip to content

Installing nextcloud server on a raspi 4 #2395

Description

@FritschM

Steps To Reproduce

  1. unpacked vm-master
  2. started sudo bash nextcloud_install_production.sh
  3. -> no new user added, no data disk, free space on root ~57GB
  4. after a few minutes, script exits with error

Expected Result

Script should finish without erros, I think

Actual Result

...
grep: /etc/apache2/apache2.conf: No such file or directory
Job for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xeu apache2.service" for details.
Sorry but something went wrong. Please report this issue to https://github.com/nextcloud/vm/issues and include the output of the error message. Thank you!
Running kernel seems to be up-to-date.

Failed to check for processor microcode upgrades.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.

No VM guests are running outdated hypervisor (qemu) binaries on this host.
ERROR: role "nextcloud_db_user" already exists
ERROR: database "nextcloud_db" already exists
PostgreSQL password: t#xxxxxxxxxxxxcr
[⣾⣽⣻⣾⣽⣻⣾⣽⣻⣾⣽⣻⣾⣽⣻⣾⣽⣻]
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Suggested packages:
apache2-doc apache2-suexec-pristine | apache2-suexec-custom www-browser
The following NEW packages will be installed:
apache2
0 upgraded, 1 newly installed, 0 to remove and 8 not upgraded.
Need to get 0 B/97.8 kB of archives.
After this operation, 546 kB of additional disk space will be used.
Selecting previously unselected package apache2.
(Reading database ... 109449 files and directories currently installed.)
Preparing to unpack .../apache2_2.4.52-1ubuntu4.1_arm64.deb ...
Unpacking apache2 (2.4.52-1ubuntu4.1) ...
Setting up apache2 (2.4.52-1ubuntu4.1) ...
Could not execute systemctl: at /usr/bin/deb-systemd-invoke line 142.
apache-htcacheclean.service is a disabled or a static unit not running, not star
ting it.
Processing triggers for man-db (2.10.2-1) ...
Processing triggers for ufw (0.36.1-4build1) ...
Rules updated for profile 'OpenSSH'
Skipped reloading firewall
Scanning processes...
Scanning processor microcode...
Scanning linux images...

Running kernel seems to be up-to-date.

Failed to check for processor microcode upgrades.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.

No VM guests are running outdated hypervisor (qemu) binaries on this host.
ERROR: Module rewrite does not exist!
ERROR: Module headers does not exist!
ERROR: Module proxy does not exist!
ERROR: Module proxy_fcgi does not exist!
ERROR: Module setenvif does not exist!
ERROR: Module env does not exist!
ERROR: Module mime does not exist!
ERROR: Module dir does not exist!
ERROR: Module authz_core does not exist!
ERROR: Module alias does not exist!
ERROR: Module ssl does not exist!
ERROR: Module mpm_prefork does not exist!
systemctl restart apache2.service failed
sudo: php: command not found

Screenshots, Videos, or Pastebins

No response

Additional Context

Linux version 5.15.0-1015-raspi (buildd@bos02-arm64-077) (gcc (Ubuntu 11.2.0-19ubuntu1) 11.2.0, GNU ld (GNU Binutils for Ubuntu) 2.38) #17-Ubuntu SMP PREEMPT Mon Sep 12 13:14:51 UTC 2022

Build Version

Linux version 5.15.0-1015-raspi (buildd@bos02-arm64-077) (gcc (Ubuntu 11.2.0-19ubuntu1) 11.2.0, GNU ld (GNU Binutils for Ubuntu) 2.38) #17-Ubuntu SMP PREEMPT Mon Sep 12 13:14:51 UTC 2022

Environment

By using the scripts

Environment Details

Raspi 4 with 64GB Falshdisk.

Activity

  1. enoch85 commented on Sep 28, 2022

    @enoch85
    Member

    Sorry, but I don't have a RPi 4 to test this on. It should work to install from scratch, but it was a long time since I tested it.

  2. vithurshanselvarajah commented on Oct 21, 2022

    @vithurshanselvarajah

    Can you let me know what version of Ubuntu you are running? I'll install it on my Pi4 this weekend and test it out for you.

    From what i can see. Some packages are not installing so it could be your running a older version of Ubuntu that doesnt support PHP8.1 perhaps.

  3. enoch85 commented on Oct 22, 2022

    @enoch85
    Member
  4. FritschM commented on Oct 22, 2022

    @FritschM
    Author

    I did a reinstallation of ubuntu server yesterday. Now apache2 is working again. Seemed to be a wrong setting in apache2.conf (i removed it in the past, "Never do things in desperation" |-). So I looked forward now ... Thanks so far. ;-)

  5. vithurshanselvarajah commented on Oct 22, 2022

    @vithurshanselvarajah

    @FritschM so all working now and i don't need to test anything?

  6. enoch85 commented on Oct 22, 2022

    @enoch85
    Member

    Would be nice if we could get a confirmation that the image I linked actually works out of the box. 👍🏼

  7. FritschM commented on Oct 22, 2022

    @FritschM
    Author
  8. vithurshanselvarajah commented on Oct 22, 2022

    @vithurshanselvarajah

    Understood. Will check tomorrow and report back

  9. enoch85 commented on Oct 22, 2022

    @enoch85
    Member

    No. Not out of the box. Image is only ubuntu server without Nextcloud Mit freundlichen Grüßen Matthias Fritsch Baden - Think global, sharing is caring!!
    …
    -------------------------------------------------- -- Von /e/ Mail gesendet. Am 22. Oktober 2022 17:56:45 MESZ schrieb Daniel Hansson @.>:
    Would be nice if we could get a confirmation that the image I linked actually works out of the box. 👍🏼 -- > Reply to this email directly or view it on GitHub: #2395 (comment) You are receiving this because you were mentioned. Message ID: @.
    >

    Well, question was if the installer scripts work "out of the box" with that image?

  10. enoch85 commented on Oct 22, 2022

    @enoch85
    Member

    Understood. Will check tomorrow and report back

    Thanks!! ☝🏻

  11. vithurshanselvarajah commented on Oct 24, 2022

    @vithurshanselvarajah

    Sorry for the delay on this.

    Had heavy winds last night and my house is currently powerless.

    Will report back on this as soon as i get power back!

  12. enoch85 commented on Nov 2, 2022

    @enoch85
    Member

    Hi, just curious - any progress here?

  13. enoch85 commented on Dec 26, 2022

    @enoch85
    Member

    @vithusel Are you still out of power? :)

  14. vithurshanselvarajah commented on Dec 26, 2022

    @vithurshanselvarajah

    @enoch85 oh god. so sorry! Slipped my mind completely. Will check tomorrow and report back!

  15. enoch85 commented on Dec 27, 2022

    @enoch85
    Member

    @vithusel Thanks! :)

  16. vithurshanselvarajah commented on Dec 27, 2022

    @vithurshanselvarajah

    @vithusel Thanks! :)

    The install script is in progress.

    Stupidly i seem to have misplaced my ssd so im stuck on installing to a slow sd card. Ill leave it to install overnight as its taking forever and will report in when im back at work tomorrow

  17. enoch85 commented on Dec 28, 2022

    @enoch85
    Member

    @vithusel So what's the outcome? :)

  18. vithurshanselvarajah commented on Dec 28, 2022

    @vithurshanselvarajah

    @vithusel So what's the outcome? :)

    Confirmed to be working. No issues :)

  19. enoch85 commented on Dec 28, 2022

    @enoch85
    Member

    Horaay! :D

    Thanks for testing!

  20. pinned this issue on Dec 28, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions